Introduction to Verilog
and ModelSim

(Part 3 — Using ModelSim)

b



HDL Simulator

 ModelSim
- Widely used in the industry
- Can simulate either/both VHDL or/and Verilog
- Has GUI interface (editor, waveform viewer)

» Alternative: Icarus Verilog
— Open source simulation tool
- Purely a Verilog simulator
- Requires separate waveform viewer




Starting ModelSim

» Click on the ModelSim icon to start
- A Welcome Screen appears (if run for the first time)
- To skip this, check on the ‘Don't show..." check-box
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Access comprehensive Model Sim documentation:
Select Help > ModelSim PDF Bookcase t\ I
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. e i ; Select Jumpstart to
[ Don't show this dialog again Use ModalSim now! Jumpstart Close




Main Screen

 The main screen shows available libraries
» Let's create a project to work on...

im ALTERA STARTER EDITION 10.1d - Custom Altera

File Edit Miew Compile Simulate Add Lbrary Tools Layout Bookmarks Window Help
|B-= w2 s o-nE N cERA| v 1 e s wumein v

‘ ColumnLayout [R11GoLunns vl ‘ : N W |

*|name |Type |Path | [
g--m zZ0model Library $MODEL_TECHY salterasvhdl/izz0made!

g--m ZZ0model_ver Library $MODEL_TECH/. falterafverilog/Zz0mod

-l altara Library $MODEL_TECH/. falterasvhdlialtera

g--m altera_Insim Library $MODEL_TECH/. falterasvhdl/altera_lnsim

g--m altera_Insim_ver Library $MODEL_TECH!. falterasverilogialtera_l...

g--m altera_mf Library $MODEL_TECH/. falterasvhdl/altera_mf m
] m altera_mf_ver Library FMODEL_TECH/ /falterasverilogsaltera_mf

g--m altera_wver Library FMODEL_TECH!. falterasverilog/altera

+-fl At Library $MODEL_TECH;. falterasvhdl/altgxh

-fll aton_lib Library $MODEL_TECH/. falterasvhdlialigsh

g--m altog=h_ver Library FMODEL_TECH/ salterasverilogialtgxh

=4l ariagx Library $MODEL_TECH!. /alterasvhdl/arriags

+-fl arriags_hssi Library $MODEL_TECH/. falterafvhdliarriag<_hssi

g--m arriags_hssi_ver Library $MODEL_TECH/. falterasverilogsarriags...

g--m arriags_ver Library FMODEL_TECH/ salterasverilog/arriags

+-fl, armiaii Library $MODEL_TECH!. falterasvhdl/arriaii

] m arriaii_hssi Library FMMODEL_TECH/. falterasvhdl/arriaii_hssi

g--m arriaii_hssi_ver Library FMMODEL_TECH/. falterasverilogiarriaii_...

-l ariaii_pcie_hip Library FMODEL_TECH/ falterasvhdliariaii_pei

g--m arriaii_pcie_hip_ver Library FMODEL_TECH/ falterafverilogsarriaii_...

g--m arriaii_ver Library $MODEL_TECHY. falterasverilogsarriaii

=4l amiaiigz Library $MODEL_TECH!. falterarvhdl/artialige

+-fl, arriaiigz_hssi Library $MODEL_TECH/. falterafvhdliarriaiigz_h...

) fll arriaiigz_hssi_ver Library $MODEL_TECH/ falterafverilogsarriaiigz...

g--m arriaiigz_pcie_hip Library $MODEL_TECH/ salterasvhdlfarriaiinz_p...
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Menu: Create New Project

« Select 'File > New > Project...’

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version
Edit View Compile Simulate Add Library Tools Layout Bookmarks Window Help

e & Directory
Open...

Load I

Cloze

Impart * Debug Archive...

E "Ity $MODEL_TECH./alterasvhdl/220model

Save CIACS L MODEL_TECHY. falterarverilog/220ma..

Save A5.. ry $MODEL_TECH!. falterasvhdlfaltera,

Repart.. ry $MODEL_TECH/ falterasvhdlfaltera_Insim

Change Directary... ry  $MODEL_TECH/. faltera/verilog/altera ..

Use Source.. ry $WMODEL_TECH!. salterasvhdlsaltera_mf B
Source Directory... ry $WMODEL_TECH!. falterasverilograltera_mf

ry $MODEL_TECH/. faltera/verilogfaltera

DriEEEE. . vy $MODEL_TECH/./alterasvhdl/altgxb

Enviranmeant ry $MODEL_TECH/. falterasvhdl/altg=h
= - ry $MODEL_TECH/. faltera/verilogfaltg=h

Page Setup.. ry $MODEL_TECH/ falterasvhdlfarriags

ry $MODEL_TECH/ falterasvhdlfarriage_hssi
ry $MODEL_TECH/ falterasverilogiarriags...
Recent Directories $MODEL_TECH/. salterasveriloglarriag.
Raecent P;oiects oY FMODEL_TECH/. falterasvhdlfarriaii

ry FMODEL_TECH/. falterasvhdlfarriaii_hssi
ry $MODEL_TECH/. falterasverilogiarriaii_...
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Close Window

Cluit

TR ST TE T Crarally $MODEL_TECH/. falterasvhdlfarriaii_pci...

ﬂ--m arriaii_pcie_hip_ver Library $MODEL_TECH/. falterasverilogiarriaii_...

ﬂ--m arriaii_ver Library $MODEL_TECH/. falterasverilogiarriaii

+-flL arriaiigz Library $MODEL_TECH/ falterasvhdlfarriaiigz

ﬂ--m arriaiigz_hssi Library $MODEL_TECH/. falterasvhdlfarriaiigz_h...

+-fl arriaiigz_hssi_ver Library $MODEL_TECH/ falterasverilogiarriaiigz...

+)-fl. arriaiigz_pcie_hip Library $MODEL_TECH/. falterasvhdliarriaiigz_p...
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Creating a Project

e Dialog box to create a new project:

 Enter a project
. Name here J
i |

Create Project

Froject Mame

|test3iﬂ

—Project Location

|fhnmefazmanftempfcheckfgmclﬂ

Browwse. .. |

—Default Library Mame

|w::| rk

— Copy =ettings From

|31:| 1/modelsim ase/modelsim. ini

 Copy Library Mappings © Reference Library Mappings

Bronwse. . |

OK — Caneel |

~

\\

\\\ :
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T
#(\ Enter the path3 A
\ZCL\uSers\publiC\mOdeISim\<name\?//
r// \\/ :\\
A )
\’i Click This!
(" -
\__ ‘ 4 /
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file:///home/c:/users

Adding ltems

* You will be given a chance to select next task
- You may use this, or get those options for menu

'L_t Add items to the Project .

Click on the icon to add items of that type:—
,/'"'\// oY \/ \\
/// : \
. Click This! |
Create Mew File Add Existing File f \\,
Create Simulation Create Mew Folder
Close |




Adding Items (cont.)

» Select 'Project > Add to Project > EXisting

File...'

Tools Layout Bookmarks Window

Help
Edit

Execute
Bemaove from Project
Update

“ Layout [NoDesign ﬂ |

| Statui Type

Simulation Configuratian...
Eolder...

Froject Settings...

]l Library =

| Project

K
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# Loading project testsim

# reading /home/share/application/altera-13. Ospl/modelsim_ase/linux/. . /modelsim. ini 0
# Loading project testsim

kodelSim=

Froject : testsim |<MNo Design Loaded: <M Contexts




Add Existing Files to Project

* You can browse for your file(s) and add multiple
selections to your project

- select previously created files PaaAeS

Add file to Proj{ct - Browse

-._'1'1_ i ‘
—File Mame % forfile(s)  ~
|| ( =
|‘home fazman/temp /check /qmel0/logic_and?. v /ho Browse... | \\ . . Y
— N
—Add file as type Folder
|default ﬂ |T|:|1:| Lewel j

i« Reference fram current location " Copy to project direc
ik | Zanc
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// A “ \ - h ) \\\

A ) -~ Name of selected
_ Click This! |

~file(s) appear here .~
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o 7 @
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Adding New ltems

» Select 'Project > Add to Project > New File...'

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version
File Edit Yieww Compile Simulate aAdd Tools Layout Bookmarks Window Help
| 8- w2 s s . Ed s S & H Layout [Woliesign | ‘
. Erecute -
J ColumnLayout [A11G0lunns
Bemowve from FProject Existing File...
| Name |Statui Type | UPdatE Optirization Canfiguration...
i ] Sirmulation Configuration. .
[n] logic_andz v *  Verilog Project Setiings... =l q
E logic_andz _th.y ? Yerlog Ueruar o uoe oA Eolder.
Bl =
[ Cibrary Project 4]
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# Project file shomesazman/temp/check/myltraining werilog/code/testsin mpf was not found. A
# Unable to open project.
# Loading project testsim
ModelSim= _
d|
Project : testsim |<Mo Design Loaded= 02/053116 07:58:38 Ak y




Add New Files to Project

* Provide a suitable filename (*.v)
- Default path is the project path

[
/ Browseto

Create Project File

-._'f' \\” N \
—File MName /\ select path =

1o |;|'l E_tE-' st v Browse. /I \7/\7//\7

— Add file as type Folder
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Systemv ilog ‘ K | T | ~— Enter file name A
— \ for new module
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Project View with Loaded Files

* You should see the selected files...

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version

Eile Edit ¥iew Compile Simulate Add Project Tools Layout Bookmarks Window Help
B3 L iBBooio-AEN||cEER|| e
‘ Layout [MoDesign J ColumnLayout A11Columns
¥|Name |StatudType  |Drde|Modified |

|h] logic_test.v ®  Werilog 2 0302716 08:46:44 PM

] logic_and2 v P Werilog 0 02/05A16 07:56:38 AM Y

] logic_andz_tb.v 2 Werilog 1 02/05/16 05:04:08 Ab
I Library | #F Project e
[ Transcript HE + & x|
# Loading project testsim
kodelSim:=

Project : testsim |<Mo Design Loaded: <Mo Context= v




Menu: Edit Verilog Source

* Right click on a source file and select 'Edit’
— Or, simply double-click on filename

[ ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version
File Edit iew Compile Simulate Add Project Tools Layout Bookmarks Window Help

=T B oo G || Layou adesign v |

‘ ColumnLayout [B11Columns b

trainir il

¥|Name |StatugType | Orde|Modified | [
|E logic_testy P warilon ® 03/02/16 06:46:44 P
|E logic_andz v 02/03/16 07:56:35 &AM
; Execule .0d-
|E logic_and2_th.y 02/03/16 08:04:08 AM
Compile "
Add to Project "

Remove from Project
Close Project
Update

Froperties...
Froject Settings...

e :
[ Cibrary | E Project <3
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# Loading project testsim i

ModelSim=

Froject : testsim |<Mo Design Loaded= logic_testy




Editing Verilog Source

* You can create/modify source from within

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version

Eile Edit ¥iew Compile Simulate Add Source Tools Layout Bookmarks Window Help
|B-@ w2 @
J Layout [NoDesign | J ColumnLayout [A11Calumns
| X% 0 Bl %
roject - fhomesazmansdocumenttraining/verilogicodestestsim =3 4 & X/
¥|Mame |StatuéType | Orde|Modified
[h] 1ogic_testy % Varilog 2 03/02/16 05:46:44 PM é ?ﬁdﬁteiiﬂgi;_agfu&hput& inputB, outputl);
h] logic_andz v 9 Verilog 0 02/05/16 07:58:35 AM 3 oueput outputsy
@ logic_andz_th.v ? Vetilog 1 02/05/16 05:04:05 A 4 req outpuks;
5 always @ (lnputh or inputE)
3 begin
7 outputd = inpuktd & inputB;
g end
a endmodule
10
I
= = -
Ik Cibrary | #4 Project | EHE! El =
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# Loading project testsim |
ModelSim:=
7|
Ln: 1 Col 0 | |Project : testsim |<No Design Loadsd: 075838 AM




Menu: Remove Verilog Source

 You can remove source from a project

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version

Eile Edit Wiew Compile Simulate aAdd Project Tools Layout Bookmarks Window Help
=T ¢ tises
J Layout [NoDesign | J ColumnLayout [A11Calumns w| ‘
| xasx %
¥|Mame |StatuéType | Orde|Modified |
|E| logic_testw Edit s "302AE 05:46:44 PM
IE logic_andzZ v c ; /0516 07:558:38 AM
Ih] logic_andz_tay o 205416 08:04:08 &M
Compile -
Add to Project
ve fram Proj
Clase Project
Update
Properties...

Project Settings...

A Library | #¥ Project K

[-1 Transcript e + & x|

# Loading project testsim

ModelSim=

Project : testsim |<Mo Design Loaded= logic_testy




Removing Verilog Source

* With option to delete

|2 Remove Proje + O X

Remove file from project?

T Delete from disk as well

DK* Cancel




Menu: Compile Verilog Source

* To compile, select 'Compile > Compile All’

delSim ALTERA STARTER EDITION 10.1d - Custom Altera Version
Eile Edit ¥iew T4 Simulate Add Project Tools Layout Bookmarks  Mindow

Help

| B - 5 g gComme- 5
A Compile Options...
I Layout NoDesi

Gl

alumnLayout [A11columns

aystemC Link...

jName C All

[h] logic_and2. Compile Selecied |og O 02/04¢416 10:18:50 PM

[h] logic_and2_ Campile Order... og 1 02/04/16 10:19:10 P
Compile Report...
Campile Summary...

i Cibrary | #¥ Project | HE

{4 Transcript s + & x|
# Loading project testsim Ak |

# reading shomesshare/application/altera-13. Ospl/modelsim_ aselinuxs. . /modelsim. ini
# Loading project testsim

MaodelSim=

Project : testsim |<Mo Design Loaded= Werilog

e




Compile Verilog Source

[ ModelSim ALTERA STARTER ERITION 10.1d - Custom Altera Version
File Edit ¥iew Compile Simulate Add Project Tools Layout Bookmarks Window k Help
|8 - w %0 SRR Y ]x@@@@@]®’%@§;ﬁ§%@
Laynut|NoDe31gn Cnluanayout|AllCnlu.rms J if . B, B3 oE . E]
r|Name |StatuType |Orde|Mod|fed | |
[h] logic_and2.v | Verilog 0 02/04/16 10:16:50 PM
[h] logic_and2_th.v | Merilog 1 024416 10:19:10 PM
\ /
N

\

A Transcript

# Compile of logic andZ. v was successful.

\

# 2 complles

ModelSims

\JJ# Compile of logic_and2_th. v was successful//

0 failed with no errors.

Project : testsim |<Mo Design Loaded=

Context=

> Syntax is okay. A
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 Once completed you should see notifications
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Positive results! |

it DOES NOT mean
that your design
IS correct!




Menu: Simulate

e Select 'Simulate > Start Simulation...'

ModelSim ALTERA STARTER EDITION 10.1d - Custom Altera Version

Eile Edit Miew Compile N Add Project Tools Layout Bookmarks Window Help
‘ = Dq % F i . \i@ i
‘ Layout NoDesign Runtime Optians...
R Bun | 3
| ame Step "
[h] 1ogic_andz.v Restart 10:15:50 PM
[h] Iogic_andz_th.v ' 10:19:10 PM
Break Break,
End Simulation
1A I
{h} Library = Project |
-4 Transcript + & x|
# Compile of logic_and2 th. v was successful. Ak
# 2 compiles, 0 failed with no errors.
# Load canceled
tAodel Sim= _
Project : testsim |<Mo Design Loaded= G:50 P Vv




Simulating Design

» Select your testbench code

Start Simulation

Designl VHDL | Verilog | Libraries | SDF | Otners | 3] //’*"‘\( b N
Al )
*| Mame Type Path - | Select your |
=-4h wark Library Wark /t th h dul g \\‘
J logic_ande kdodule fhomedazmandempsd -l IEE——— estbencnh mo u\s
1] Iugic_and?ktb hodule fhomedazmandemplcheckigme 0 ( from 'Work' \}/
il--m Ze0model Library FMODEL_TECH! falteradvhdlf2 2l \\
<-4 2z0madel_ver Library $MODEL_TECH/. falteradverilog/: j\ . &7/
g--ﬂ altera Library $MODEL_TECH/. falterasvhdlialte \*/\7 //
g--ﬂ altera_Insim Libwrary FrAODEL_TECH/. falteradyhdlfalte
ﬂ--ﬂ altera_lngim_wver Libwrary FMODEL_TECH/ falterasverilogs:
+-W atera mf | itirary FRACINFL TRCHS falterafehdlfalte o
Kl | -
~Design Unit{s) Resolution
work. logic_=nd2 th lrldefault hd
~Dptimization ‘
[~ Enahle optimization Optimization Options... |

oK m o




Simulating Design (cont.)

* Once loaded you should see your module(s):

ModelSim ALTERA STARTER EDITION 10.1d
Eile Edit Miew Compile Simulate Add Structure Tools Layout Bookmarks Window

X Help

R IEE Y O-MEN | 2HRN

|t es F weEAEBERE WU [t LR

Layout |Simulate ﬂ ‘

aneEEE

‘ ColumnLayout [A11Colunns -l

| 3-3-2 a9

o

H B il B

Search:

ErT T IINE

&2 Otjects —

¥|Instance

|Design unit [Design unit type | wisibi

= z logic_andé_th
Ll mygate
[

logic_andz_th Module
logic_andZ  Module

+ACC=
+3CCs|

i) #INITIAL#S logic_andZ_th Frocess | sacc outputc
#usim_capacity# Capacny/ +accs loop
~~—_ -

Library =

Project = | & sim |

* 0 #INITIAL#S

B + & x|
Type (filtered) g
Initial

2]

Transcript

+ & |

HoHHH R

2 compiles, 1 failed with 1 error.
Compile of logic_and2. v was successful.

Compile of logic_and2_ th.w failed with 1 errors.

2 compiles, 1 failed with 1 error.
Compile of logic_and2. v was successful.
Nemwnd e af Tamdie 2md? +hoer stms anecassfinl

Froject : testsim |Mow: 0 ps

Delta: 0 *

i

analyzed




Menu: Waveform Viewer

e Select 'View > Wave'

File Edit Compile  Simulate  Add
‘ . g (CallStack
e  Capacity
‘ ﬂ +  Class Browser »
‘ CalumnL ~ “O¥eL2ge »
L Dataflow
‘ £ g8 Files ()
.. .. wLibrary
% List
Locals

#|Instance  Message Viewer
=&l lagic temory List (W)
[+ m v Ohjects
.4 # wProcess
[’ #vsi Profiling r
v Project (=)
Schematic (1)
¥ Structure (2)
» Transcript
Yerification hanagement e

‘Watch

Sort

ModelSim ALTERA STARTER EDITION 10.1d

Structure Tools Layout Bookmarks

lo-BET N SEgn|
TETAT IR R Y-
3

EL

Window Help

Layoutlmﬂ|
|| ([0 o [ ) 6% |
search: [ w| #hag ﬁ?‘

¥4 9

W e |

+ & x|

$a Objects

Design unit type | Wisihi
odule +aCC= inputa
odule +aCC= inpute
Process +aCC= outputc
Capacity +aCC=

+ & x|

*  #INITIAL#S Initial

r
Filter »
Justify
ﬂ— Froperties..
p -
Library « Project | & sim |

f-] Transcript

+ & |

# 2 compiles, 1 failed with 1 error.

# Compile of logic_and2_th. v failed
# 2 compiles, 1 failed with 1 error.

# Compile of logic_and2. v was successful.

with 1 errors.

# Compile of logic_and2. v was successful.
# Nemedile afF Tamde =nd® +hoer wrms anecessfuol

Froject : testsim [Mow: 0 ps  Delta: 0 Module




Waveform Viewer

* Appears as sub-window (on first ru n)ﬂ\«vv\

ModelSim ALTERA STARTER EDITION 10.1d
File Edit Miew Compile Simulate Add Wawe Tools Layout Bookmarks  Window

Help

\

A

|89- 3@ -8 1B o2 o -HEN| S8 gH]|
l@f%%¢mﬁmamlma@;@@@ Tt

3; ﬁ?’um

Layout [Simulate hd ‘

‘ ColumnLayout [A1160 Tumns

LT YR

+ | Search: |

LS B P
&l sim - Default s H §I| $a Objects — s +| J xJ
¥|Instance |Ciesign unit | Desigr 3
=4 logic_andZ_th logic_andZ_th koduly inputa
[+ mygate logic_and2  Moduly inpute
J #IMITIAL#S logic_andz_th Proceé 4 putput

| svsim_capacity Capac Ioop

8 Processes (Active) ——mm——
¥ Name [Type (filtered)
-
El l P
Library | 4 Project | & sim | i E | >

A Transeript 0in i i i i i i ——-——

# 2 compiles,
# Compile of
# Compile of
# 2 compiles,

1 failed with 1 error.
logic_and2. v was successful.
logic_and2 th. v failed with 1 errors.
1 failed with 1 error.

|
# Compile of logic_and2. v was successful.
# Nomwnile af Tnmic and? +h oo was snccessfinl A
0 ps to 2480 ps

Project : testsim |Mow: 0 ps  Delta: 0 inputa

/ Wave viewer |
window \ /

< N//
N ST

o~
AT TN

—— m Select signal(s)

toview

. L/
N ST

o




Wave Viewer: Adding Signals

» Select signals (Ctrl-click) inputA,inputB,outputC
Right-click, select 'Add to >Wave >Selected signals'

ModelSim ALTERA STARTER EDITION 10.1d

File Edit Yiew Compile Simulate Add Objects Tools Layout Eookmarks MWindow Help - -
- . / \\ / \
J \:)vME—MH@ @@‘ /\\s‘ / \
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Insert Breakpaint
El ] | Toggle Coverage
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§-4 Transcript Radix...
sim:/logic_and?_th/inputd *
sim: /logic_andZ_th/inputE * Show
sim: /logic_andZ_th outputsc
WEIM 3>
Project : testsim [Now: 0 ps  Delta: 0 outputc /




Ready to Execute (Simulation)

 Change a few settings...

,,,’ - L
ModelSim ALTERA STARTER EDITION 10.1d //
File Edit ¥iew Compile Simulate Add Wave Tools Layout Bookmarks Windows 3 Help /
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@ fogic_an
& fogic_an..
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%" Zoomscale
~ toSps

L L T L T L
S0 ps 100 ps 150 ps 200 ps I

-4 Transcript J_ | Wave | §a Objects l-ﬂ: Processes lﬂ Likirary l&] Project l@ sitm J Rk
o

1 |

| 0 ps to 236 ps |F'mject testsim |NDW 0ps Delta: 0 |sim flogic_andz_thifinputA




Executing/Running the Simulation

* Click on Run (F9) icon...

ModelSim ALTERA STARTER EDITION 10.1d ‘(/ ‘ EaC h Cl |Ck 2 \
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J é" £ —lt ﬂ— - n i e ‘ } . ﬁ . e Saarch: ’7J P Sz . S~ /\\\ o ////
@ fogic_an
& fogic_an..
~ fogic_an... | St I —
o~ N N
— Y / \_
. N \

\‘;\/ Th IS ! \\\‘\ /
. ,,‘}/
el 2

1= [ |
-4 Transcript J_ | Wave | §a Objects l-ﬂ: Processes lﬂ Likirary l&] Project l@ sitm J Rk

| 0 ps to 236 ps |F'mject testsim |NDW 50 ps Delta: 0 |sim flogic_andz_th v




Running New Simulation

 To run a new simulation, end the current
simulation &
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Practical Session 3.1

* Implement the given logic

In truth table IA iB iC oD

- You may choose to use 0 0 0 1
‘assign’ statements or 0 0 1 1
‘always' block 0 1 0 0

e Create a suitable 0 1 1 0
testbench for the modules 1 0 0 0

» Simulate and analyze the ' 0 L 0
results to verify the 1 1 0 1
functionality of the modules 1 1 1 0

—
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